Back to overview

Wellbeing tools unavailable

May 27, 2026 at 7:20pm UTC
Affected services
feedback.bfranq.com

Resolved
May 27, 2026 at 7:33pm UTC

We’re back! Wellbeing tools should be up and running. Thanks for bearing with us.

Created
May 27, 2026 at 7:20pm UTC

The wellbeing tools are back up and running.